Creating new sites is not possible
Incident Report for Refined
Resolved
The issue has been resolved by Cloudflare.
Posted Nov 03, 2023 - 02:40 CET
Identified
The creation of the sites is failing due to a domain verification failure. This seems to be caused by an ongoing Cloudflare incident which they are mitigating. See https://www.cloudflarestatus.com/ for full details.
Posted Nov 02, 2023 - 19:03 CET
Investigating
Creating new sites is currently not possible. Existing sites are not affected.

We will post an update once we know more.
Posted Nov 02, 2023 - 17:54 CET
This incident affected: Refined Cloud US and Refined Cloud EU.