Some users are not able to log in to Refined Confluence on the cloud

Incident Report for Refined

Resolved

Atlassian has deployed a fix for this issue, and we are not seeing any further issues. If you have any questions, please contact the Refined support team at help.refined.com.
Posted Mar 24, 2026 - 11:48 UTC

Monitoring

Atlassian has implemented a fix for this issue, which should be deployed in the next hour. We are waiting for confirmation that this has resolved the problem.
Posted Mar 24, 2026 - 09:11 UTC

Investigating

We are experiencing an issue where some users are not able to log into their Refined Confluence instance. We are investigating this and working with Atlassian to understand the root cause.
Posted Mar 24, 2026 - 06:55 UTC
This incident affected: Refined Cloud US and Refined Cloud EU.