Refined Cloud outage (US)
Incident Report for Refined
Postmortem

Incident overview

On Tuesday, October 17, at 10:13 CEST, our services experienced unexpected downtime lasting 50 minutes. After a detailed investigation, we identified the root cause as a poorly executed SQL update query. We sincerely apologize for any inconvenience this may have caused you.

Corrective actions taken

Upon detecting the issue, our technical team initiated an immediate response. The following actions were taken:

  1. The problematic SQL update query was identified.
  2. Affected data was restored.

Impact on customers

We understand that this incident had a significant impact on your ability to use our services. We have taken steps to mitigate this risk in the future, including reinforcing our procedures for these types of updates with staff and emphasizing caution during such operations.

Preventive measures

To prevent a recurrence of such incidents, we are enhancing our review and approval process for SQL updates.

Customer support

Our customer support team is ready and waiting to address any concerns or questions you may have. Please do not hesitate to reach out to them at help.refined.com if you need further assistance or information.

We deeply regret any inconvenience you may have experienced, and we thank you for your patience and understanding during this time. Your trust is of utmost importance to us, and we are fully committed to ensuring the reliability and performance of our services.

Posted Oct 19, 2023 - 17:38 CEST

Resolved
This incident has been resolved.
Posted Oct 17, 2023 - 14:49 CEST
Monitoring
A fix has been implemented and we are monitoring the situation.
Posted Oct 17, 2023 - 11:02 CEST
Investigating
We’re experiencing a service outage with Refined Cloud in the US region. We apologize for any inconvenience. All users are affected. We will post an update once we know more.
Posted Oct 17, 2023 - 10:27 CEST
This incident affected: Refined Cloud US.