Refined Cloud outage

Incident Report for Refined

Resolved

This incident has been resolved.
Posted May 23, 2023 - 07:50 UTC

Investigating

We’re experiencing a service outage with Refined Cloud. We apologize for any inconvenience. All users are affected. We will post an update once we know more.
Posted May 23, 2023 - 07:49 UTC
This incident affected: Refined Cloud US.