Refined Cloud outage
Incident Report for Refined
Resolved
This incident has been resolved.
Posted Oct 14, 2020 - 03:22 CEST
Investigating
We’re experiencing a service outage with Refined Cloud. We apologize for any inconvenience. All users are affected. We will post an update once we know more.
Posted Oct 14, 2020 - 03:11 CEST
This incident affected: Refined Cloud US.