Refined Toolkit outage
Incident Report for Refined
Resolved
This incident has been resolved.
Posted Apr 28, 2021 - 11:50 CEST
Investigating
We’re experiencing a service outage with Refined Toolkit. We apologize for any inconvenience. All users are affected. We will post an update once we know more.
Posted Apr 28, 2021 - 11:49 CEST
This incident affected: Refined Toolkit US.