Refined Cloud outage
Incident Report for Refined
Resolved
This incident has been resolved.
Posted Mar 01, 2021 - 10:43 CET
Investigating
We’re experiencing a service outage with Refined Cloud. We apologize for any inconvenience. All users are affected. We will post an update once we know more.
Posted Mar 01, 2021 - 10:41 CET
This incident affected: Refined Cloud US.